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Overview

Release 3.2.7 SR is a service release of firmware/software for all In-Sight 1720 Series wafer readers running 3.20.05 firmware or later. This release corrects an issue with In-Sight firmware
that could result in a wafer reader being rendered inoperable. This event typically occurred at boot-up, halting the process and ceasing communications, which resulted in the red User LEDs
blinking in a repeating pattern. Older firmware revisions, in addition to the other In-Sight sensor models, are not affected by this issue.

This document describes Release 3.2.7 of the In-Sight Wafer ID for the In-Sight 1721 and 1722 wafer readers, which consists of In-Sight Explorer 3.2.7 and In-Sight firmware 3.20.07. The
release notes include the following topics:

e About this Release

e System Requirements

¢ New Features

¢ Changes & Fixes
¢ Known Issues

¢ Release History

¢ Firmware Update Instructions

For updated release notes, documentation and more, log on to the In-Sight Online Support Center at: www.cognex.com/support/In-Sight.asp.

Note: You must be a registered user.

About This Release

This release introduces In-Sight Explorer and a new .NET implementation of the Wafer ID user interface for the In-Sight 1720 series wafer readers. There are two installation options
available on the In-Sight CD-ROM: the .NET User Interface and the Legacy Installation (Java Applet). You should use the .NET installation unless you require the Java applet for


http://www.cognex.com/support/In-Sight.asp

backwards compatibility in a legacy situation, such as directly replacing an older, Java-based wafer reader or if your PC does not support Microsoft® Windows® .NET (for example, if the
PC is running on a Windows NT operating system). Release 3.2.7 of the In-Sight Wafer ID will be the last release to include the Java applet interface. All future releases will only include
the .NET user interface.
Notes:

e The .NET user interface is not compatible with firmware version 2.90.00; the wafer reader must be upgraded to firmware version 3.20.07 to access the .NET user interface.

e Firmware version 3.20.07 is only compatible with Java applet version 3.20.07 and higher.

e The choice of graphical user interface does not affect the programmatic interface; the serial and TCP/IP commands are backwards compatible with firmware version 2.90.00 and
earlier.

This release also introduces In-Sight Explorer for Wafer ID. In-Sight Explorer is a powerful tool to help you manage a network of wafer readers from a remote location, including outside
the clean room. In-Sight Explorer allows you to:

 Easily configure the IP address and other network settings for your wafer readers.

e View all wafer readers on the network, including In-Sight 1700 and 1701 wafer readers running the Java applet.
e Manage job files between different wafer readers.

¢ Remotely configure or debug wafer readers from anywhere on the network.

¢ Upgrade firmware on multiple wafer readers simultaneously.

¢ Drag-and-drop job and image files from the local PC to any wafer reader on the network.

¢ Copy files from one wafer reader and paste it to another wafer reader.

¢ Perform file operations, including FTP, backup, restore and clone.

¢ Configure startup conditions such as the startup job and Online mode.

¢ Set access levels and user privileges.

In-Sight Explorer can connect to both In-Sight 1720 series wafer readers running the new .NET user interface and to legacy In-Sight 1700 and 1701 readers running the Java applet
interface. Users that plan to continue using Microsoft Internet Explorer® instead of In-Sight Explorer should still use the .NET user interface, rather than the legacy Java applet.

Supported In-Sight Wafer Readers

This release contains In-Sight Explorer software and firmware for your In-Sight 1720 series wafer reader. In-Sight 1700 and 1701 wafer readers can be accessed using In-Sight Explorer,
but these wafer readers cannot be upgraded to firmware version 3.20.07 (or any firmware after 2.71.00 PR1). If an In-Sight 1700 or 1701 wafer reader is double-clicked in the In-Sight
Explorer Network pane, the Java applet Browser View will open within the In-Sight Explorer interface for the selected wafer reader.

System Requirements
.NET User Interface

Operating System Requirements



In-Sight Explorer has been tested on the following operating systems:

e Windows 2000, Service Pack 4

¢ Windows XP Professional, Service Pack 2 (or higher)

Although In-Sight Explorer may function on other operating systems, systems not meeting the preceding requirements are not supported.

Software Requirements

The Microsoft .NET Framework 1.1 SP1 must be installed on your system before installing In-Sight Explorer:
e The .NET Framework 1.1 setup package (dotnetfx.exe) is located on the In-Sight CD-ROM. Alternately, it can be downloaded from Microsoft.

¢ Service Pack 1 for NET Framework 1.1 (NDP1.1sp1-KB867460-X86.exe) is located on the In-Sight CD-ROM. Alternately, it can be downloaded from Microsoft.

Note: The Microsoft NET Framework 1.1 SP1 must be installed on the PC, even if Microsoft NET Framework 2.0 is already installed.
Legacy Installation (Java Applet)

Operating System Requirements

The legacy Java applet has been tested on the following operating systems:
e Windows 2000, Service Pack 4
¢ Windows XP Professional, Service Pack 2 (or higher)

¢ Windows NT 4.0, Service Pack 6 (or higher)

New Features

In-Sight Explorer

Launch In-Sight Explorer using the desktop shortcut or by opening the Start menu and clicking All Programs > Cognex > In-Sight > In-Sight Wafer ID 3.2.7 > In-Sight Wafer ID 3.2.7. The
Wafer ID View is the default view from In-Sight Explorer. Using the Job View to edit the underlying spreadsheet is not supported and may cause the Wafer ID application to stop
functioning properly. Refer to the /n-Sight® Explorer Help file for details on In-Sight Explorer features.

Release 3.2.7 of the In-Sight Wafer ID will be the last release to include the Java applet interface. If you plan to continue using Microsoft Internet Explorer®, you can launch the .NET user
interface from Internet Explorer to configure and monitor Wafer ID applications on the wafer reader. To open a connection to the wafer reader from Internet Explorer, enter the wafer

reader's [P address or host name of the wafer reader into the browser’s Address Bar followed by “/WaferID.html” (for example, http://192.168.0.1/WaferID.html or
http://is1721_00060b/WaferID.html).

Notes:
¢ In-Sight Explorer must be installed on the PC to access the wafer reader’s WaferID.html file using Microsoft Internet Explorer.

¢ You should update your application code to automatically launch WaferID.html, rather than issuing the wafer reader's IP address.


http://www.microsoft.com/downloads/details.aspx?FamilyID=262d25e3-f589-4842-8157-034d1e7cf3a3&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=a8f5654f-088e-40b2-bbdb-a83353618b38&displaylang=en

In-Sight .NET User Interface

Added the ability to copy Config settings to multiple Configs using the Copy Config dialog. To access the Copy Config dialog, right click on a Config name within the user interface.
Added the ability for admin-level users to rename Configs by either double-clicking the Config name within the user interface or by single-clicking the Config name and pressing F2.

Added the ability for operator-level users to switch between Configs to manually read the mark when the wafer reader cannot read the mark. To do so, an admin-level user should first
create a "View Failed" Config with human-readable light settings (for example, Config 9). This Config can be disabled. After a no read, the operator-level user can take the wafer
reader Offline and click the "View Failed" Config. Switching between Configs causes an image acquisition, allowing the user to manually read and enter the correct string without
changing the light settings on any enabled Config.

Added an Allow Rotated & Arc Regions checkbox to the Options tab. When enabled, the rotation and curve can be edited in Edit Region mode and the rotation can be edited in Edit
Size mode. Previously, the CTRL+R keyboard shortcut was used to enable editing of rotated and arc regions.

An LKxS5 option has been added to the Protocol drop-down list to enable LKx5 serial communication.
The WafIDO00.job file now supports the SET HW LKx5 serial command for compatibility only. It returns an echo of the input argument, but does not affect light settings.
Added the Mark Color checkbox to the Tuning tab. Enable this checkbox to try both black and white mark colors during the tuning process.

Added the Light checkbox to the Tuning tab. This replaces the separate Bright Field and Dark Field checkboxes. Enable this checkbox to try different light modes and power settings
during the tuning process.

Added a Custom light mode. With Custom lighting, you can determine which light rows are turned on. This is intended for the rare occasions when none of the standard light modes
provides a good image.

Added the SetConfigLEDOverride Extended Native Mode command to enable a custom light mode and to specify the light row(s) to enable. Added the GetConfigLEDOverride
command to return whether a custom light mode is enabled.

Added the GetConfigLEDOverrideMask Extended Native Mode command to retrieve the current light row(s) decimal value that is set by the SetConfigLEDOverride Extended
Native Mode command.

Added the SetConfigName and GetConfigName Extended Native Mode commands to rename individual Configs and to retrieve individual Config names.

Added the GetWaferAllEx Extended Native Mode command to retrieve all results for the most recent read, and settings for all Configs. Unlike the GetWaferAll Extended Native
Mode command, GetWaferAllEx returns the SetWaferScoreAs100 output.

Added the TuneConfigEx Extended Native Mode command to tune the specified Config. Unlike the TuneConfig Extended Native Mode command, TuneConfigEx allows you to
enable polarity-independent tuning to automatically try different light modes and power settings and to enable Mark Color tuning to try both black and white mark colors during the
tuning process.

In-Sight Legacy Installation (Java Applet)

An LKxS5 option has been added to the Protocol drop-down list to enable LKx5 serial communication.
The WafIDO00.job file now supports the SET _HW LKx5 serial command for compatibility only. It returns an echo of the input argument, but does not affect light settings.
Added the Mark Color checkbox to the Tuning dialog. Enable this checkbox to try both black and white mark colors during the tuning process.

Added the Light checkbox to the Tuning dialog. This replaces the separate Bright Field and Dark Field checkboxes. Enable this checkbox to try different light modes and power
settings during the tuning process.



¢ Added the GetWaferAllEx Extended Native Mode command to retrieve all results for the most recent read, and settings for all Configs. Unlike the GetWaferAll Extended Native
Mode command, GetWaferAllEx returns the SetWaferScoreAs100 output.

¢ Added the TuneConfigEx Extended Native Mode command to tune the specified Config. Unlike the TuneConfig Extended Native Mode command, TuneConfigEx allows you to
automatically try different light modes and power settings and to enable Mark Color tuning to try both black and white mark colors during the tuning process.

Changes & Fixes

NOTE: Change Request numbers (CR#) have been included (where applicable) to improve tracking of Known Issues reported via Cognex Technical Support.
The Changes & Fixes below are Changes & Fixes for both the In-Sight .NET User Interface and the Legacy Installation (Java Applet).
o The WaflD00 LKx5.job file is not included with firmware version 3.20.07. The default WafID00.job file has been updated to support LKx5 commands.
¢ The default WafID00.job file is not backwards compatible with firmware version 2.90.00

¢ The TuneConfig Extended Native Mode command now returns the correct NumRead and Percent output values when the TuneConfig <Flag> parameter value is equal to 2. (CR#
45252)

e The SetConfig Extended Native Mode command now properly sets the <Enable>, <Retry>, <BComp> and <Thresh> parameter values. Previously, when the SetConfig command
was issued, the <Enable>, <Retry>, <BComp> and <Thresh> parameter values were not correctly set and a -2 status code may have been returned. (CR# 43696)

¢ The <Color> input parameter no longer supports the Auto value (i.e., "2"). If the Color parameter value is set to Auto, a -2 status code is returned. The <Color> parameter has been
replaced by the Mark Color tuning flag.

In-Sight .NET User Interface

e PC Host can no longer be used to access the wafer reader user interface. The wafer reader user interface can now be accessed by In-Sight Explorer or a Microsoft Internet Explorer
browser. In-Sight Explorer must be installed on the PC to access the wafer reader user interface using Microsoft Internet Explorer.

e The Index.html, System.html and .JAR files are no longer included.

e The Color drop-down list is now referred to as the Mark Color drop-down list.

e The Auto option is no longer available from the Mark Color drop-down list. Users should instead use the Mark Color checkbox on the Tuning tab.

¢ Added polarity-independent tuning. With polarity-independent tuning, the wafer reader automatically tries both black and white mark colors during tuning if the Mark Color
checkbox is enabled. As part of polarity-independent tuning, the Light Modes have been renamed Mode 0 - 11, instead of BF1 - BF3, and DF1 - DF8. The SetConfigLightMode
Extended Native Mode command is unchanged; it still uses array indexes 0 - 11, which are identical to the new Mode numbers. In previous releases, if the Mark Color value was

Auto, the reader would only tune for black marks with bright field (BF) light modes and for white marks with dark field (DF) light modes. This could cause misreads if the reader was
not mounted exactly perpendicular, resulting in dark field images from nominal bright field lighting, and vice-versa.

Old Light Mode | New Light Mode | Light Rows Lit

OFF 0 OFF (Use this mode only when an external light source is required in a specialized application.)
BF1 1 Rows 7 and 8
BF2 2 Rows 6 and 7
BF3 3 Rows 8 and 9
DF1 4 Rows 4 and 5




DF2 5 Rows 10 and 11

DF3 6 Rows 3 and 4

DF4 7 Rows 11 and 12

DF5 8 Rows 2 and 3

DF6 9 Rows 12 and 13

DF7 10 Rows 0 and 1

DF8 11 Rows 14 and 15

N/A Custom Individual Light Rows can be enabled or disabled.

¢ The File tab is not available in the In-Sight Explorer Wafer ID View. Job files and image files can be opened and saved from the In-Sight Explorer File menu.
e The System Settings page is no longer available.

o Information previously contained in the Info tab can now be accessed from the About tab.

o

Network Settings can now be modified using the In-Sight Connection Manager or from the In-Sight Explorer Network Settings dialog (Sensor menu > Network Settings).

o

Serial Settings can now be viewed or modified using the In-Sight Explorer Serial Port Settings dialog (Sensor menu > Serial Port Settings).

o

The User List can now be viewed or modified using the In-Sight Explorer User List dialog (Sensor menu > User List).
o Startup options can now be viewed or modified using the In-Sight Explorer Startup dialog (Sensor menu > Startup).
In-Sight Legacy Installation (Java Applet)
¢ The Auto option is no longer available from the Color drop-down list. Users should instead use the Mark Color checkbox on the Tuning dialog.

Consult the Release History for changes and fixes in previous releases.

Known Issues

This section describes known issues with the In-Sight software, including any known workarounds. Change Request numbers (CR#) have been included to improve tracking of Known
Issues reported via Cognex Technical Support.

In-Sight .NET User Interface

¢ Toolbars and Panes may not show up properly if undocked when layout is saved. If any of the following items are undocked when the layout is saved, they may not appear properly
the next time In-Sight Explorer is launched. (CR# 40300)

o Toolbars

o Menu Bars

o In-Sight Files pane

o In-Sight Network pane

e When a display is set to the Large size (120 DPI) setting (Control Panel > Display > Settings > Advanced), there may be problems with how the Clone To, Restore From, Options and
User List dialogs are resized and aligned. Workaround: If you do resize the display to 120 DPI, you will need to manually resize the dialogs. (CR# 40452)



o If a wafer reader is cloned or restored, the user list will not be cleared. Therefore, any user names that were added to the user list before the wafer reader has been cloned or restored
will remain on the wafer reader after it has been cloned or restored. Workaround: After the wafer reader has been cloned or restored, manually add or remove users from the user list.
(CR#40423)

e When naming files, avoid using the dot character (".") because files with a dot character in their name cannot be copied to or deleted from the wafer reader without first renaming the
file and removing the dot character; file names with a dot will also cause an error during a restore operation. (CR# 44900)

o The wafer reader can store over 256 files, but when viewing the file list from an FTP prompt, only 256 files are listed and the Save and Open dialogs can only display 255 files. (CR#
36161)

¢ The wafer reader's Host Name cannot be used in the web address to suppress the HTTP Logon dialog when connecting to the wafer reader. Workaround: The wafer reader's IP
address must be used in the web address. For example, "http://IPAddress/filename?isSL=username+password". (CR# 44401)

o Ifajob file is saved to the PC, rather than to the wafer reader, the Get File Native Mode command returns a temporary file name. (CR# 42951)

 Internet Explorer security settings may prevent the WaferID.html file from loading properly. (CR# 45503) One or more of the following workarounds may be necessary to allow the
file to load properly:

o From Internet Explorer, click Tools > Internet Options > Connections tab > LAN Settings > Advanced. From the Proxy Settings dialog, add the wafer reader's IP address to the
Exceptions text box.

o From Internet Explorer, click Tools > Internet Options > Security tab. Select the Local intranet icon and click Sites. From the Local intranet dialog, ensure that the "Include all
sites that bypass the proxy server" checkbox is enabled.

o From Internet Explorer, click Tools > Internet Options > Security tab. Select the Local intranet icon and click Sites. From the Local intranet dialog, click Advanced. Enter the
wafer reader IP address in the "Add this Web site to the zone" text box and click Add. Repeat for any additional wafer readers.

In-Sight Legacy Installation (Java Applet)

e When a job file is saved from the Java applet with a file extension that is capitalized (for example, “.JOB”), then the applet is closed and reopened, the job file will not appear in the
list of jobs in the File tab. To rename the job with a lowercase file extension, load and resave the job using the In-Sight PC Host. (CR# 38138)

e When using the default job, if a DNS server is specified in the Network dialog, the user must wait at least 45 seconds before viewing files on other systems from the Save & Load
dialog after the power has been cycled on the reader.

¢ To avoid display problems when running the In-Sight PC Host, close other programs that may be using DirectDraw and reduce the PC’s color depth and resolution. Both the color
depth and resolution can be modified from the Windows Display Properties dialog. These steps will increase the amount of available memory on the PC’s video card.

¢ Ifajob containing a large number of functions is loaded while a firmware upgrade is attempted in the In Sight PC Host, too little flash RAM may be available and the upgrade may
be interrupted. If this occurs, open the System menu and select New Job, then reattempt the upgrade.

¢ Repeated use of the Back and Forward buttons on some Internet browsers can cause a “Too Many Users” message box to appear. If this message appears, and the browser interface is
“locked,” close the message box, then close and reopen the browser. Alternatively, leave the browser open and wait for the lock on the browser interface to timeout after 3 minutes.

e The User List can only be modified using the In-Sight PC Host interface. All selections in the User List tab on the System Settings page in the browser interface are grayed out.

e The Host Table can only be modified using the In-Sight PC Host interface. The Host Table button in the Network tab on the System Settings page in the browser interface is grayed
out.

¢ When changing Network System Settings from the browser interface, you must wait several seconds before cycling power on the reader in order for the changes to be properly saved
to flash RAM. Cycling power too soon may corrupt the flash RAM.



Release History

Release 2.90.00 ¢ Release 2.90.00 was the first release of firmware/software for the new In-Sight 1720 series wafer readers.
¢ Added the SetWaferScoreAs100 and GetWaferScoreAs100 Native Mode commands to configure and retrieve the Autoscore Non-Alphanumeric settings.

¢ Added support of several LKx5 serial commands. A new wafer reader job file, WafID0O0 LKx5.job, was included on the In-Sight 1700 CD. This job file
must be loaded on the reader to use the LKx5 commands. For more information, see the In-Sight® 1700 Series Wafer Reader User Manual, Section 8: LKx5
Commands.

¢ In the Acquirelmage property sheet, the Light Power parameter name was changed to Light Control, and the Light Power sub-parameter names were
changed to Light Enable to more clearly describe their usage. (CR# 41188)

Legacy Installation (Java Applet)

¢ Added the Autoscore Non-Alphanumeric checkbox to the Options tab of the In-Sight 1720 series Java applet. When enabled, character positions fielded as
dashes (-), dots (.) and spaces automatically score 100 points regardless of what character or symbol is actually in that space.

e Updated the uncompressed strings that are returned when the Compressed 8 decoding option is selected (from the Advanced dialog) for IBM and BC 412
compressed barcodes. For more information, refer to Tech Note: Reading IBM and BC 412 Barcodes.

Firmware 3.20.07 Update Instructions

In-Sight .NET User Interface

Detailed instructions on updating an In-Sight 1720 series to firmware version 3.20.07 from a previous version are contained in Installing In-Sight® 1720 Series Wafer Readers hardware
manual, Appendix A.

In-Sight Legacy Installation (Java Applet)

Detailed instructions on updating an In-Sight 1720 series to firmware version 3.20.07 from a previous version are contained in the /n-Sight® 1700 Series Wafer Reader User Manual,
Appendix A.

NOTE: When updating an In-Sight wafer reader from a PC Host located on a different subnet, you must select the .UPD firmware file from the PC Host you are logged on to.
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